Hyperlinks aren't getting pasted in other programs

Please ask all kinds of questions about Notesbrowser
Post Reply
janlafata
Posts: 4
Joined: Wed Aug 05, 2009 5:17 am

Hyperlinks aren't getting pasted in other programs

Post by janlafata » Thu Sep 09, 2010 11:59 pm

I have several notes with hyperlinks included. They are in blue and underlined and all that. Anyway when I copy text, and the link underneath it to Word or Windows Live Mail, the URL appears but just in plain text. In other words it's not a link. I can't figure out why this is. It's a link in Notesbrowser, but not in anything I paste it to!!!

User avatar
Dirk Schwenke
NB-Team
Posts: 154
Joined: Thu Dec 29, 2005 11:31 pm
Location: Hamburg
Contact:

Re: Hyperlinks aren't getting pasted in other programs

Post by Dirk Schwenke » Fri Sep 10, 2010 2:27 pm

Yes you are right. The behavior is because links in Notesbrowser are only text - nothing added.

If you copy and paste Links from Notesbrowser to other application, it depends what happens. Usually, the application knows what to do with, for example, http://www.notesbrowser.com
But not all applications do.

For example if you post http://www.notesbrowser.com in an new Email of Microsoft Outlook and press return it will get blue and underlined and work as a link. If you do this with Excel or Word, it will not work but only after you select 'Insert Hyperlink'. This Hyperlink is more that the text you see and non-standard. We don't want to use non-standard thinks as long as we can avoid it. So its not a bug because many applications handle links like Notesbrowser does, but I can understand it is not easy for the user to accept its not a bug..

We will think about this issue in the future, maybe introducing more complex hyperlinks, but for now it's only text. Sorry.

janlafata
Posts: 4
Joined: Wed Aug 05, 2009 5:17 am

Re: Hyperlinks aren't getting pasted in other programs

Post by janlafata » Fri Sep 10, 2010 3:51 pm

Thanks for clearing that up! On the matter of pasting in Word or Excel, I'm not sure if I did it right or not, but it came out ok. In an empty space on the Word page I just clicked "Insert Hyperlink" and when a window came up that asked for "Text to Display" and "Address" I just pasted in a hyperlink I copied from Notesbrowser. Was that the correct way to do it for Word and Excel or is there an easier way?

User avatar
Dirk Schwenke
NB-Team
Posts: 154
Joined: Thu Dec 29, 2005 11:31 pm
Location: Hamburg
Contact:

Re: Hyperlinks aren't getting pasted in other programs

Post by Dirk Schwenke » Fri Sep 10, 2010 4:51 pm

Yes this is the easiest way to insert hyperlinks as far as I know.

Post Reply